Перейти к основному содержимому

Редактирование ячеек

Ввод содержимого в ячейку​

Ввод данных вручную​

  • Нажмите на нужную ячейку на листе.
  • Введите текст, число, дату или время и нажмите Enter.

Ввод формулы​

  • Нажмите на ячейку, в которой должен отображаться результат формулы.
  • Введите знак =.
  • Создайте формулу. Для этого можно использовать:
    • константы и операторы вычислений, например =3-2*5+12
    • ссылки на ячейки и операторы вычислений, например =A1/A2
    • встроенные функции, например =MAX(C46;D46)
  • Нажмите Enter.
Примечание

Строчные буквы в формулах автоматически преобразуются в прописные.

Для вставки гиперссылки в ячейку можно воспользоваться одним из описанных ниже способов.

Через контекстное меню​

  • Нажмите правой кнопкой мыши на ячейку и выберите Вставить ссылку

Контекстное меню DHTMLX Spreadsheet с выделенным пунктом «Вставить ссылку»

  • В появившемся окне введите Текст и Ссылку, затем нажмите Сохранить

Диалог вставки ссылки DHTMLX Spreadsheet с полями Текст и Ссылка

Через кнопку на панели инструментов​

  • Выделите ячейку и нажмите кнопку Вставить ссылку на панели инструментов

Панель инструментов DHTMLX Spreadsheet с выделенной кнопкой «Вставить ссыл�ку»

  • В появившемся окне введите Текст и Ссылку, затем нажмите Сохранить

Через меню​

  • Выделите ячейку и перейдите: Вставка -> Вставить ссылку в меню

Меню Вставка DHTMLX Spreadsheet с пунктом «Вставить ссылку»

  • В появившемся окне введите Текст и Ссылку, затем нажмите Сохранить.
  • Выделите ячейку, содержащую ссылку, которую нужно скопировать
  • Во всплывающем окне нажмите значок Копировать

Всплывающее окно ссылки DHTMLX Spreadsheet с выделенным значком «Копировать»

  • Выделите ячейку, содержащую ссылку, которую нужно отредактировать
  • Во всплывающем окне нажмите значок Редактировать

Всплывающее окно ссылки DHTMLX Spreadsheet с выделенным значком «Редактировать»

  • Выделите ячейку, содержащую ссылку, которую нужно удалить
  • Во всплывающем окне нажмите значок Удалить ссылку

Всплывающее окно ссылки DHTMLX Spreadsheet с выделенным значком «Удалить ссылку»

Использование выпадающих списков в ячейках​

Вы можете создать выпадающий список в ячейке, чтобы пользователи могли выбирать нужный элемент из него.

Создание выпадающего списка путём ручного ввода​

  • Выделите ячейку или диапазон ячеек, в которых нужно создать список

  • Перейдите: Данные -> Проверка данных в меню

  • Выберите критерий Список элементов

  • Введите элементы, которые должны отображаться в выпадающем списке

  • Нажмите кнопку Сохранить

Диалог проверки данных DHTMLX Spreadsheet, создание выпадающего списка из списка элементов

Создание выпадающего списка из диапазона​

  • Введите элементы, которые должны отображаться в выпадающем списке

  • Выделите ячейку или диапазон ячеек, в которых нужно создать список

  • Перейдите: Данные -> Проверка данных в меню

  • Выберите критерий Список из диапазона

  • Выберите диапазон вашего списка

  • Нажмите кнопку Сохранить

Диалог проверки данных DHTMLX Spreadsheet, создание выпадающего списка из диапазона ячеек

Удаление проверки из ячейки​

Вы можете отключить использование выпадающего списка в ячейке. Для этого:

  • Выделите нужную ячейку или диапазон ячеек, из которых нужно удалить выпадающий список
  • Перейдите: Данные -> Проверка данных в меню
  • Выберите опцию Удалить проверку

Меню Данные DHTMLX Spreadsheet с опцией «Удалить проверку» в разделе «Проверка данных»

Ввод одинаковых данных в нескольких ячейках​

Вы можете вводить одинаковые данные в несколько ячеек, используя маркер заполнения для автоматического заполнения ячеек на листе. Подробности см. ниже.

Автозаполнение ячеек содержимым​

Вы можете автоматически заполнять ячейки данными. Вот как это работает:

1. Выделите ячейку (ячейки), данные которой будут использованы в качестве основы для заполнения других ячеек.

2. Введите данные в выбранную ячейку (ячейки). Автозаполнение работает несколькими способами:

  • копирование значения

Например, чтобы создать ряд 4,4,4,4..., введите 4 только в первой ячейке.

  • следование шаблону
    • чтобы создать ряд 1, 2, 3, 4, 5, ..., введите 1 и 2 в первые две ячейки.
    • чтобы создать ряд 1, 3, 5, 7, 9, ..., введите 1 и 3 в первые две ячейки.
    • чтобы создать ряд 2, 4, 6, 8, 10, ..., введите 2 и 4 в первые две ячейки.
    • помимо чисел, в шаблоне можно использовать буквы, например, чтобы создать ряд 1, a, 2, b, 3, a, 4, b, ..., введите 1, a, 2, b в первые четыре ячейки.
    • чтобы продолжить число в конце текста, введите первые значения, например, чтобы создать ряд item1, item2, item3, ..., введите item1 и item2 в первые две ячейки.
    • чтобы создать ряд дат, введите дату в первую ячейку: каждая следующая ячейка получит следующий день.
  • повторение текста

Например, чтобы создать ряд North, South, North, South, ..., введите North и South в первые две ячейки. Числа в ячейках с форматом Text повторяются так же.

3. Перетащите маркер заполнения

Автозаполнение в DHTMLX Spreadsheet, перетаскивание маркера заполнения для копирования данных ячейки

Копирование ячеек в Excel и из Excel​

Вы можете копировать ячейки с помощью Ctrl (Cmd) + C и вставлять их с помощью Ctrl (Cmd) + V внутри Spreadsheet, а также между Spreadsheet и Microsoft Excel:

  • внутри Spreadsheet ячейки сохраняют значения, формулы, стили, числовые форматы и ссылки. Ссылки на ячейки в формулах смещаются на новую позицию
  • в Excel вставленные ячейки получают значения (результаты формул, а не сами формулы), стили (включая размер шрифта), объединённые ячейки и ссылки. Строки, скрытые фильтром, пропускаются
  • ячейки, скопированные из Excel, при вставке в Spreadsheet сохраняют значения, стили (включая размер шрифта), числовые форматы, объединённые ячейки и ссылки

Блокировка ячеек​

Вы можете блокировать ячейки, чтобы защитить их значения от изменений. При блокировке ячейки в её правом верхнем углу появляется серый значок «замка». Заблокированные ячейки не реагируют на попытки их редактирования. Программы чтения с экрана озвучивают отклонённое редактирование: «The cell is locked» для одной ячейки или «Locked cells were not changed», если в выделенном диапазоне есть заблокированные ячейки.

Заблокированные ячейки в DHTMLX Spreadsheet, помеченные серым значком замка в правом верхнем углу

Для блокировки или разблокировки ячейки воспользуйтесь одним из описанных ниже способов:

Блокировка ячеек через кнопку на панели инструментов​

  • Выделите ячейки, которые нужно заблокировать/разблокировать (они не обязаны быть смежными).
  • Нажмите кнопку Заблокировать ячейку на панели инструментов.

Панель инструментов DHTMLX Spreadsheet с выделенной кнопкой «Заблокировать ячейку»

Блокировка ячеек через контекстное меню​

  • Нажмите правой кнопкой мыши на ячейку или диапазон ячеек, которые нужно заблокировать/разблокировать.
  • Выберите опцию «Заблокировать/Разблокировать ячейку» в появившемся контекстном меню.

Контекстное меню DHTMLX Spreadsheet с выделенным пунктом «Заблокировать/Разблокировать ячейку»