Zum Hauptinhalt springen

Arbeiten mit Zeilen und Spalten

DHTMLX Spreadsheet ermöglicht Ihnen das Hinzufügen und Entfernen von Spalten und Zeilen, das automatische Anpassen der Spaltenbreite an den Inhalt, das Fixieren und Aufheben der Fixierung von Spalten und Zeilen sowie das Ein- und Ausblenden von Spalten und Zeilen uber Toolbar-Schaltflachen, Menüoptionen und Kontextmenüoptionen der Zelle.

Hinzufügen/Entfernen von Zeilen und Spalten​

Zeilen hinzufügen​

Um eine neue Zeile hinzuzufügen, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Zeile (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der gewünschten Zeile aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie entweder auf die Schaltfläche Rows in der Toolbar und wählen Sie die Option Add row above

DHTMLX Spreadsheet Rows toolbar button with the Add row above option highlighted

  • oder wählen Sie die Menüoption Insert und dann Rows -> Add row above

DHTMLX Spreadsheet Insert menu showing Rows and the Add row above option

  • oder klicken Sie mit der rechten Maustaste auf die Zeile oder eine Zelle in der Zeile und wählen Sie Rows -> Add row above

DHTMLX Spreadsheet context menu with the Rows submenu showing Add row above

Zeilen entfernen​

Um eine Zeile zu entfernen, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Zeile (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der Zeile aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie auf die Schaltfläche Rows in der Toolbar und wählen Sie die Option Remove row

DHTMLX Spreadsheet Rows toolbar button with the Remove row option highlighted

  • oder wählen Sie die Menüoption Insert und dann Rows -> Remove row

DHTMLX Spreadsheet Insert menu showing Rows and the Remove row option

  • oder klicken Sie mit der rechten Maustaste auf die Zeile oder eine Zelle in der Zeile und wählen Sie Rows -> Remove row

DHTMLX Spreadsheet context menu with the Rows submenu showing Remove row

Hinweis

Um mehrere Zeilen auf einmal zu entfernen: Wahlen Sie die Zeilen aus, klicken Sie mit der rechten Maustaste, um das Kontextmenü aufzurufen, und wählen Sie Rows -> Remove rows [ids].

Info

Wenn die ausgewählte Zelle innerhalb einer zusammengeführten Zelle liegt, werden alle Zeilen der zusammengeführten Zelle entfernt. Details finden Sie im Artikel Zellen zusammenführen.

Spalten hinzufügen​

Um eine neue Spalte hinzuzufügen, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Spalte (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der gewünschten Spalte aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie entweder auf die Schaltfläche Columns in der Toolbar und wählen Sie die Option Add column left

DHTMLX Spreadsheet Columns toolbar button with the Add column left option highlighted

  • oder wählen Sie die Menüoption Insert und dann Columns -> Add column left

DHTMLX Spreadsheet Insert menu showing Columns and the Add column left option

  • oder klicken Sie mit der rechten Maustaste auf die Spalte oder eine Zelle in der Spalte und wählen Sie Columns -> Add column left

DHTMLX Spreadsheet context menu with the Columns submenu showing Add column

Spalten entfernen​

Um eine Spalte zu entfernen, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Spalte (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der Spalte aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie auf die Schaltfläche Columns in der Toolbar und wählen Sie die Option Remove column

DHTMLX Spreadsheet Columns toolbar button with the Remove column option highlighted

  • oder wählen Sie die Menüoption Insert und dann Columns -> Remove column

DHTMLX Spreadsheet Insert menu showing Columns and the Remove column option

  • oder klicken Sie mit der rechten Maustaste auf die Spalte oder eine Zelle in der Spalte und wählen Sie Columns -> Remove column

DHTMLX Spreadsheet context menu with the Columns submenu showing Remove column

Hinweis

Um mehrere Spalten auf einmal zu entfernen: Wahlen Sie die Spalten aus, klicken Sie mit der rechten Maustaste, um das Kontextmenü aufzurufen, und wählen Sie Columns -> Remove columns [ids].

Info

Wenn die ausgewählte Zelle innerhalb einer zusammengeführten Zelle liegt, werden alle Spalten der zusammengeführten Zelle entfernt. Details finden Sie im Artikel Zellen zusammenführen.

Spaltenbreite automatisch anpassen​

Um die Spaltenbreite so zu ändern, dass sie automatisch dem längsten Inhalt der Spalte entspricht, können Sie:

  • auf den Cursor zum Anpassen der Größe einer Spalte im Tabellenkopf doppelklicken

DHTMLX Spreadsheet column header with the resize cursor for autofitting column width

  • oder die folgenden Schritte ausführen:

1. Klicken Sie mit der linken Maustaste auf das 3-Punkte-Symbol der Spalte

DHTMLX Spreadsheet column context menu opened from the three dots icon

2. Wahlen Sie Columns -> Fit to data

DHTMLX Spreadsheet Columns submenu with the Fit to data option for autofit column width

Spaltenbreite und Zeilenhöhe festlegen​

Spaltenbreite festlegen​

Um eine genaue Breite für Spalten festzulegen, führen Sie die folgenden Schritte aus:

1. Wählen Sie eine Spalte oder eine Zelle in der Spalte aus. Um mehrere Spalten zu ändern, wählen Sie einen Zellbereich aus, der sie umfasst.

2. Klicken Sie mit der rechten Maustaste auf die Auswahl oder drücken Sie Shift + F10 bzw. die Menütaste und wählen Sie Columns -> Column width. Derselbe Befehl ist im Menü des 3-Punkte-Symbols der Spalte verfügbar.

DHTMLX Spreadsheet context menu with the Columns submenu showing Column width

3. Geben Sie im Dialog Column width die Breite in Pixeln ein und klicken Sie auf Apply oder drücken Sie Enter.

DHTMLX Spreadsheet Column width dialog with the width in pixels and the Cancel and Apply buttons

Zeilenhöhe festlegen​

Um eine genaue Höhe für Zeilen festzulegen, führen Sie die folgenden Schritte aus:

1. Wählen Sie eine Zeile oder eine Zelle in der Zeile aus. Um mehrere Zeilen zu ändern, wählen Sie einen Zellbereich aus, der sie umfasst.

2. Klicken Sie mit der rechten Maustaste auf die Auswahl oder drücken Sie Shift + F10 bzw. die Menütaste und wählen Sie Rows -> Row height.

DHTMLX Spreadsheet context menu with the Rows submenu showing Row height

3. Geben Sie im Dialog Row height die Höhe in Pixeln ein und klicken Sie auf Apply oder drücken Sie Enter.

DHTMLX Spreadsheet Row height dialog with the height in pixels and the Cancel and Apply buttons

Anwendung der neuen Größe​

Der Dialog zeigt die aktuelle Größe der ersten Spalte bzw. Zeile des ausgewählten Bereichs an und wendet die neue Größe auf jede Spalte bzw. Zeile dieses Bereichs an. Wenn mehrere Bereiche ausgewählt sind, wird der zuletzt ausgewählte Bereich verwendet.

Die Größe wird auf ganze Pixel gerundet. Die Mindestbreite einer Spalte beträgt 20 px und die Mindesthöhe einer Zeile 10 px: Ein kleinerer positiver Wert wird durch das Minimum ersetzt. Solange das Feld leer ist oder der Wert keine positive Zahl ist, ist die Schaltfläche Apply deaktiviert.

Die Schaltfläche Cancel oder Esc schließt den Dialog ohne Änderungen. Screenreader kündigen die neue Größe an, zum Beispiel „Column width set to 120 pixels".

Änderung rückgängig machen​

Die neue Größe kann mit Ctrl (Cmd) + Z rückgängig gemacht werden.

Um die Änderung im Code zu verarbeiten, verwenden Sie die Actions resizeCol und resizeRow.

Zeilen und Spalten fixieren/Fixierung aufheben​

Zeilen fixieren​

Um Zeilen bis zu einer bestimmten Zeile zu fixieren, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Zeile (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der gewünschten Zeile aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie entweder auf die Schaltfläche Rows in der Toolbar und wählen Sie die Option Freeze up to row [id]

DHTMLX Spreadsheet Rows toolbar button with the Freeze up to row option highlighted

  • oder wählen Sie die Menüoption Edit und dann Freeze -> Freeze up to row [id]

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Freeze up to row

  • oder klicken Sie mit der rechten Maustaste auf eine Zeile oder eine Zelle in der Zeile und wählen Sie Rows -> Freeze up to row [id]

DHTMLX Spreadsheet context menu with the Rows submenu showing Freeze up to row

Fixierung von Zeilen aufheben​

(In den folgenden Abbildungen sind Zeilen bis zur Zeile 5 fixiert)

Um die Fixierung von Zeilen aufzuheben, führen Sie einen der folgenden Schritte aus:

  • Klicken Sie entweder auf die Schaltfläche Rows in der Toolbar und wählen Sie die Option Unfreeze rows

DHTMLX Spreadsheet Rows toolbar button with the Unfreeze rows option highlighted

  • oder wählen Sie die Menüoption Edit und dann Freeze -> Unfreeze rows

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Unfreeze rows

  • oder klicken Sie mit der rechten Maustaste auf eine beliebige Zelle und wählen Sie Rows -> Unfreeze rows

DHTMLX Spreadsheet context menu with the Rows submenu showing Unfreeze rows

Spalten fixieren​

Um Spalten bis zu einer bestimmten Spalte zu fixieren, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Spalte (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der gewünschten Spalte aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie entweder auf die Schaltfläche Columns in der Toolbar und wählen Sie die Option Freeze up to column [id]

DHTMLX Spreadsheet Columns toolbar button with the Freeze up to column option highlighted

  • oder wählen Sie die Menüoption Edit und dann Freeze -> Freeze up to column [id]

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Freeze up to column

  • oder klicken Sie mit der rechten Maustaste auf eine Spalte oder eine Zelle in der Spalte und wählen Sie Columns -> Freeze up to column [id]

DHTMLX Spreadsheet context menu with the Columns submenu showing Freeze up to column

Fixierung von Spalten aufheben​

(In den folgenden Abbildungen sind Spalten bis zur Spalte D fixiert)

Um die Fixierung von Spalten aufzuheben, führen Sie einen der folgenden Schritte aus:

  • Klicken Sie entweder auf die Schaltfläche Columns in der Toolbar und wählen Sie die Option Unfreeze columns

DHTMLX Spreadsheet Columns toolbar button with the Unfreeze columns option highlighted

  • oder wählen Sie die Menüoption Edit und dann Freeze -> Unfreeze columns

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Unfreeze columns

  • oder klicken Sie mit der rechten Maustaste auf eine beliebige Zelle und wählen Sie Columns -> Unfreeze columns

DHTMLX Spreadsheet context menu with the Columns submenu showing Unfreeze columns

Zeilen und Spalten ein-/ausblenden​

Zeilen ausblenden​

Um eine Zeile auszublenden, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Zeile (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der gewünschten Zeile aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie entweder auf die Schaltfläche Rows in der Toolbar und wählen Sie die Option Hide row(s) [id]

DHTMLX Spreadsheet Rows toolbar button with the Hide rows option highlighted

  • oder klicken Sie mit der rechten Maustaste auf eine Zeile oder eine Zelle in der Zeile und wählen Sie Rows -> Hide row(s) [id]

DHTMLX Spreadsheet context menu with the Rows submenu showing Hide rows

Info

Wenn sich die aktive Zelle in einer Zeile befindet, die ausgeblendet wird, wechselt die aktive Zelle zur ersten sichtbaren Zeile darunter, und die Auswahl wird auf diese Zelle reduziert. Wenn darunter keine sichtbaren Zeilen vorhanden sind, wechselt sie zur letzten sichtbaren Zeile darüber.

Zeilen einblenden​

Um ausgeblendete Zeilen einzublenden, führen Sie einen der folgenden Schritte aus:

  • Klicken Sie entweder auf das "Pfeil"-Symbol, das im Zeilenkopf anstelle der ausgeblendeten Zeile(n) erscheint

(In der folgenden Abbildung sind die Zeilen 8 und 11 ausgeblendet)

DHTMLX Spreadsheet rows header with the arrows icon indicating hidden rows

  • oder wählen Sie Zeilen oder mehrere Zellen aus, sodass die ausgeblendeten Zeilen in die Auswahl eingeschlossen sind, klicken Sie mit der rechten Maustaste, um das Kontextmenü aufzurufen, und wählen Sie Rows -> Show rows

(In der folgenden Abbildung ist die Zeile 8 ausgeblendet)

DHTMLX Spreadsheet context menu with the Rows submenu showing Show rows

  • oder wählen Sie Zeilen oder mehrere Zellen aus, sodass die ausgeblendeten Zeilen in die Auswahl eingeschlossen sind, und drücken Sie Ctrl (Cmd) + Shift + 9. Wählen Sie zum Beispiel die Zeilen 2-4 aus, um die ausgeblendete Zeile 3 einzublenden. Wenn die Auswahl keine ausgeblendeten Zeilen enthält, kündigen Screenreader „No hidden rows in the selection" an

Spalten ausblenden​

Um eine Spalte auszublenden, führen Sie die folgenden Schritte aus:

1. Wahlen Sie eine Spalte (durch Klicken auf ihre Kopfzeile) oder eine Zelle in der gewünschten Spalte aus.

2. Wahlen Sie eine der folgenden Aktionen:

  • Klicken Sie entweder auf die Schaltfläche Columns in der Toolbar und wählen Sie die Option Hide column(s) [id]

DHTMLX Spreadsheet Columns toolbar button with the Hide columns option highlighted

  • oder klicken Sie mit der rechten Maustaste auf eine Spalte oder eine Zelle in der Spalte und wählen Sie Columns -> Hide column(s) [id]

DHTMLX Spreadsheet context menu with the Columns submenu showing Hide columns

Info

Wenn sich die aktive Zelle in einer Spalte befindet, die ausgeblendet wird, wechselt die aktive Zelle zur ersten sichtbaren Spalte rechts davon, und die Auswahl wird auf diese Zelle reduziert. Wenn rechts keine sichtbaren Spalten vorhanden sind, wechselt sie zur letzten sichtbaren Spalte links.

Spalten einblenden​

Um ausgeblendete Spalten einzublenden, führen Sie einen der folgenden Schritte aus:

  • Klicken Sie entweder auf das "Pfeil"-Symbol, das im Spaltenkopf anstelle der ausgeblendeten Spalte(n) erscheint

(In der folgenden Abbildung sind die Spalten C und E ausgeblendet)

DHTMLX Spreadsheet columns header with the arrows icon indicating hidden columns

  • oder wählen Sie Spalten oder mehrere Zellen aus, sodass die ausgeblendeten Spalten in die Auswahl eingeschlossen sind, klicken Sie mit der rechten Maustaste, um das Kontextmenü aufzurufen, und wählen Sie Columns -> Show columns

(In der folgenden Abbildung ist die Spalte C ausgeblendet)

DHTMLX Spreadsheet context menu with the Columns submenu showing Show columns

  • oder wählen Sie Spalten oder mehrere Zellen aus, sodass die ausgeblendeten Spalten in die Auswahl eingeschlossen sind, und drücken Sie Ctrl (Cmd) + Shift + 0. Wenn die Auswahl keine ausgeblendeten Spalten enthält, kündigen Screenreader „No hidden columns in the selection" an