跳到主要内容

行与列操作

DHTMLX Spreadsheet 支持通过工具栏按钮、菜单选项和单元格上下文菜单选项来添加和删除列与行、自动调整列宽以适应内容、冻结和解冻列与行,以及隐藏和显示列与行。

添加/删除行和列​

添加行​

要添加新行,请按以下步骤操作:

1. 选择一行(单击其表头)或该行中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 行 按钮,选择 在上方添加行 选项

DHTMLX Spreadsheet Rows toolbar button with the Add row above option highlighted

  • 或在菜单中选择 插入 选项,然后选择 行 -> 在上方添加行

DHTMLX Spreadsheet Insert menu showing Rows and the Add row above option

  • 或右键单击该行或行中的某个单元格,选择 行 -> 在上方添加行

DHTMLX Spreadsheet context menu with the Rows submenu showing Add row above

删除行​

要删除行,请按以下步骤操作:

1. 选择一行(单击其表头)或该行中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 行 按钮,选择 删除行 选项

DHTMLX Spreadsheet Rows toolbar button with the Remove row option highlighted

  • 或在菜单中选择 插入 选项,然后选择 行 -> 删除行

DHTMLX Spreadsheet Insert menu showing Rows and the Remove row option

  • 或右键单击该行或行中的某个单元格,选择 行 -> 删除行

DHTMLX Spreadsheet context menu with the Rows submenu showing Remove row

备注

要一次删除多行:选择这些行,右键单击调出上下文菜单,然后选择 行 -> 删除行 [ids]。

信息

如果选中的单元格位于合并单元格内,则会删除该合并单元格的所有行。详细信息请查阅合并单元格一文。

添加列​

要添加新列,请按以下步骤操作:

1. 选择一列(单击其表头)或该列中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 列 按钮,选择 在左侧添加列 选项

DHTMLX Spreadsheet Columns toolbar button with the Add column left option highlighted

  • 或在菜单中选择 插入 选项,然后选择 列 -> 在左侧添加列

DHTMLX Spreadsheet Insert menu showing Columns and the Add column left option

  • 或右键单击该列或列中的某个单元格,选择 列 -> 在左侧添加列

DHTMLX Spreadsheet context menu with the Columns submenu showing Add column

删除列​

要删除列,请按以下步骤操作:

1. 选择一列(单击其表头)或该列中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 列 按钮,选择 删除列 选项

DHTMLX Spreadsheet Columns toolbar button with the Remove column option highlighted

  • 或在菜单中选择 插入 选项,然后选择 列 -> 删除列

DHTMLX Spreadsheet Insert menu showing Columns and the Remove column option

  • 或右键单击该列或列中的某个单元格,选择 列 -> 删除列

DHTMLX Spreadsheet context menu with the Columns submenu showing Remove column

备注

要一次删除多列:选择这些列,右键单击调出上下文菜单,然后选择 列 -> 删除列 [ids]。

信息

如果选中的单元格位于合并单元格内,则会删除该合并单元格的所有列。详细信息请查阅合并单元格一文。

列宽自动适应​

要更改列宽,使其自动适应列中最长的内容,您可以:

  • 双击表头中列的调整光标

DHTMLX Spreadsheet column header with the resize cursor for autofitting column width

  • 或按以下步骤操作:

1. 左键单击列的三点图标

DHTMLX Spreadsheet column context menu opened from the three dots icon

2. 选择 列 -> 适应数据

DHTMLX Spreadsheet Columns submenu with the Fit to data option for autofit column width

设置列宽和行高​

设置列宽​

要设置列的精确宽度,请按以下步骤操作:

1. 选择一列或该列中的某个单元格。若要更改多列,请选择跨越这些列的单元格区域。

2. 右键单击选区,或按 Shift + F10 或 Menu 键,然后选择 列 -> 列宽。该命令也可在列的三点图标菜单中找到。

DHTMLX Spreadsheet context menu with the Columns submenu showing Column width

3. 在列宽对话框中输入以像素为单位的宽度,然后单击应用或按 Enter。

DHTMLX Spreadsheet Column width dialog with the width in pixels and the Cancel and Apply buttons

设置行高​

要设置行的精确高度,请按以下步骤操作:

1. 选择一行或该行中的某个单元格。若要更改多行,请选择跨越这些行的单元格区域。

2. 右键单击选区,或按 Shift + F10 或 Menu 键,然后选择 行 -> 行高。

DHTMLX Spreadsheet context menu with the Rows submenu showing Row height

3. 在行高对话框中输入以像素为单位的高度,然后单击应用或按 Enter。

DHTMLX Spreadsheet Row height dialog with the height in pixels and the Cancel and Apply buttons

新尺寸的应用方式​

对话框显示所选区域中第一列或第一行的当前尺寸,并将新尺寸应用于该区域内的每一列或每一行。如果选择了多个区域,则使用最后选择的区域。

尺寸会四舍五入为整数像素。列的最小宽度为 20 px,行的最小高度为 10 px:小于最小值的正数会被替换为最小值。当输入框为空或输入的值不是正数时,应用按钮不可用。

取消按钮或 Esc 会关闭对话框且不做任何更改。屏幕阅读器会播报新的尺寸,例如"Column width set to 120 pixels"。

撤销更改​

可以使用 Ctrl (Cmd) + Z 撤销新的尺寸。

要在代码中处理该更改,请使用 resizeCol 和 resizeRow actions。

冻结/解冻行和列​

冻结行​

要将行冻结到某一行,请按以下步骤操作:

1. 选择一行(单击其表头)或该行中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 行 按钮,选择 冻结到第 [id] 行 选项

DHTMLX Spreadsheet Rows toolbar button with the Freeze up to row option highlighted

  • 或在菜单中选择 编辑 选项,然后选择 冻结 -> 冻结到第 [id] 行

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Freeze up to row

  • 或右键单击某行或行中的某个单元格,选择 行 -> 冻结到第 [id] 行

DHTMLX Spreadsheet context menu with the Rows submenu showing Freeze up to row

解冻行​

(下图中行已冻结到第 5 行)

要解冻行,请选择以下任一操作:

  • 单击工具栏中的 行 按钮,选择 解冻行 选项

DHTMLX Spreadsheet Rows toolbar button with the Unfreeze rows option highlighted

  • 或在菜单中选择 编辑 选项,然后选择 冻结 -> 解冻行

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Unfreeze rows

  • 或右键单击任意单元格,选择 行 -> 解冻行

DHTMLX Spreadsheet context menu with the Rows submenu showing Unfreeze rows

冻结列​

要将列冻结到某一列,请按以下步骤操作:

1. 选择一列(单击其表头)或该列中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 列 按钮,选择 冻结到第 [id] 列 选项

DHTMLX Spreadsheet Columns toolbar button with the Freeze up to column option highlighted

  • 或在菜单中选择 编辑 选项,然后选择 冻结 -> 冻结到第 [id] 列

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Freeze up to column

  • 或右键单击某列或列中的某个单元格,选择 列 -> 冻结到第 [id] 列

DHTMLX Spreadsheet context menu with the Columns submenu showing Freeze up to column

解冻列​

(下图中列已冻结到 D 列)

要解冻列,请选择以下任一操作:

  • 单击工具栏中的 列 按钮,选择 解冻列 选项

DHTMLX Spreadsheet Columns toolbar button with the Unfreeze columns option highlighted

  • 或在菜单中选择 编辑 选项,然后选择 冻结 -> 解冻列

DHTMLX Spreadsheet Edit menu with the Freeze submenu showing Unfreeze columns

  • 或右键单击任意单元格,选择 列 -> 解冻列

DHTMLX Spreadsheet context menu with the Columns submenu showing Unfreeze columns

隐藏/显示行和列​

隐藏行​

要隐藏行,请按以下步骤操作:

1. 选择一行(单击其表头)或该行中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 行 按钮,选择 隐藏行 [id] 选项

DHTMLX Spreadsheet Rows toolbar button with the Hide rows option highlighted

  • 或右键单击某行或行中的某个单元格,选择 行 -> 隐藏行 [id]

DHTMLX Spreadsheet context menu with the Rows submenu showing Hide rows

信息

如果活动单元格所在的行被隐藏,活动单元格会移动到其下方第一个可见行,选区缩小为该单元格。如果下方没有可见行,则移动到上方最后一个可见行。

显示行​

要显示已隐藏的行,请选择以下任一操作:

  • 单击行表头中代替隐藏行出现的"箭头"图标

(下图中第 8 行和第 11 行已隐藏)

DHTMLX Spreadsheet rows header with the arrows icon indicating hidden rows

  • 或选择包含隐藏行的行或多个单元格,右键单击调出上下文菜单,然后选择 行 -> 显示行

(下图中第 8 行已隐藏)

DHTMLX Spreadsheet context menu with the Rows submenu showing Show rows

  • 或选择行或多个单元格,使隐藏的行包含在选区中,然后按 Ctrl (Cmd) + Shift + 9。例如,选择第 2-4 行即可显示隐藏的第 3 行。如果选区中没有隐藏的行,屏幕阅读器会播报"No hidden rows in the selection"

隐藏列​

要隐藏列,请按以下步骤操作:

1. 选择一列(单击其表头)或该列中的某个单元格。

2. 选择以下任一操作:

  • 单击工具栏中的 列 按钮,选择 隐藏列 [id] 选项

DHTMLX Spreadsheet Columns toolbar button with the Hide columns option highlighted

  • 或右键单击某列或列中的某个单元格,选择 列 -> 隐藏列 [id]

DHTMLX Spreadsheet context menu with the Columns submenu showing Hide columns

信息

如果活动单元格所在的列被隐藏,活动单元格会移动到其右侧第一个可见列,选区缩小为该单元格。如果右侧没有可见列,则移动到左侧最后一个可见列。

显示列​

要显示已隐藏的列,请选择以下任一操作:

  • 单击列表头中代替隐藏列出现的"箭头"图标

(下图中 C 列和 E 列已隐藏)

DHTMLX Spreadsheet columns header with the arrows icon indicating hidden columns

  • 或选择包含隐藏列的列或多个单元格,右键单击调出上下文菜单,然后选择 列 -> 显示列

(下图中 C 列已隐藏)

DHTMLX Spreadsheet context menu with the Columns submenu showing Show columns

  • 或选择列或多个单元格,使隐藏的列包含在选区中,然后按 Ctrl (Cmd) + Shift + 0。如果选区中没有隐藏的列,屏幕阅读器会播报"No hidden columns in the selection"